2018-12-18

(PHP) PHPのsession設定を修正しました。

WebサーバーPHPバージョン5.4から7.2に上げたら、PukiWiki1.5.1が正常に動作しなくなりましたが、先ほど問題解決しました。

 

昨夜の調査で、PHPセッション周りにエラーがあることが分かりました。

続きを調べてみると、

/var/lib/php/session

というディレクトリの設定が不適切で、PHPプロセスから書き込みができない状態になっていました。

 

原因は、PHP-FPMインストールした後の設定作業が抜けていたこ

PHPバージョンを上げるときに、PHP-FPMも再インストールしていました。

「/var/lib/php/session」を使う作業ユーザーデフォルトでは「apache」になっているようです。(前の設定を見てないのが不確か)

とりあえず、これを「apacheからnginx」に変更したら、PHPセッションが正常に動作するようになりました。

 

Google検索解決のヒントになる情報がいろいろ得られたので、あまり苦労せずに解決できました。

いつも有益情報提供してくださる皆様にこの場を借りて感謝申し上げます

どうもありがとうございました。

記事への反応 -
  • [PHP] PukiWiki 1.5.1でログインできない

    WebサーバーのPHPを5.4から7.2にアップデートした。 PukiWikiも最新の1.5.1に変更した。 https://pukiwiki.osdn.jp/?PukiWiki/Download/1.5.1   ページの編集にはパスワードをかけて、ログインするようにし...

    • (PHP) PHPのsession設定を修正しました。

      WebサーバーのPHPをバージョン5.4から7.2に上げたら、PukiWiki1.5.1が正常に動作しなくなりましたが、先ほど問題が解決しました。   昨夜の調査で、PHPのセッション周りにエラーがあること...

    • anond:20181218000454

      うんち

    • まずは公式ドキュメントを読んでみる

      PukiWikiのバージョンアップに伴う変更点を確認してみる。 https://pukiwiki.osdn.jp/?PukiWiki/Download/1.5.1#ifdf9221 ユーザー管理機能および認証方法の拡張 Sessionを利用したForm認証が追加され、デフ...

    • (PHP) XAMPP Portableの利用

      PHP7のテスト環境として「XAMPP」のポータブル版を利用してみよう。 https://www.apachefriends.org/jp/index.html   今見たら、最新のバージョンはPHP7.3.0だったが、今使ってるPHPは7.2なので、1つ古...

記事への反応(ブックマークコメント)

アーカイブ ヘルプ
ログイン ユーザー登録
ようこそ ゲスト さん